頻繁に使うものではないですが、Wordpressに標準で使えるようになっている「インポートツール」で下記のようなエラーが出て使えない場合があります。

( ! ) Strict standards: Declaration of WP_Import::bump_request_timeout()
should be compatible with WP_Importer::bump_request_timeout($val) in ・・・

実は私も、最近このエラーがでていることに気が付きました。
滅多にデータをインポートすることはないのでいいのですが、いざ使いたいときにこのエラーで使えないのは困りますので、事前に修正しておくといいと思います。
修正手順は下記の通りです。

1.FTP等で次のファイルを開きます。
 「wp-content/plugins/wordpress-importer/wordpress-importer.php 」

2.1110行目付近を下記のように修正します。
  修正前:function bump_request_timeout()
 修正後:function bump_request_timeout($unused)

3.修正した「wordpress-importer.php」を元の場所に上書きします。

これだけで、エラーを消すことができます。
「インポートツール」はそれほど使われない機能なので、アップデートもほとんどされていないようです。
何か大きな不具合があった時には、この問題も一緒に修正されるでしょうが、現状は上記手順で個別修正するしかないようです。

普段使わなくても、転ばぬ先の杖として、事前に修正しておくことをおすすめします。


☆もしこの記事が気に入っていただけましたなら、SNSでシェアをお願いします。非常に励みになります。 ☆フォロー・配信購読はこちら